Our uBank app and Online Banking are not available

Incident Report for ubank

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 21:57 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 21:55 AEST

Update

WE’RE BACK! Customers can now use their ubank app and online banking. Our team will continue to monitor closely. Again, we’re sorry for any inconvenience caused.
Posted Jul 10, 2025 - 21:54 AEST

Update

Upon further investigation, we have confirmed that card payments (both physical and digital) are not impacted. Our technical team continues to investigate the issue with uBank app and Online Banking.
Posted Jul 10, 2025 - 19:52 AEST

Update

We are continuing to investigate this issue.
Posted Jul 10, 2025 - 18:52 AEST

Investigating

We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Jul 10, 2025 - 18:51 AEST
This incident affected: ubank app, Card payments, and Online banking.