New customers are unable to join us or apply for Home Loans right now
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Sep 23, 2023 - 18:57 AEST
Investigating
We’re working to resolve this as quickly as possible and we’ll update this page the second it’s fixed.
Posted Sep 23, 2023 - 17:26 AEST
This incident affected: ubank app and Direct home loans.