Planned maintenance to our app
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 23:14 AEST
Update
We are continuing to investigate this issue.
Posted Jun 20, 2022 - 23:13 AEST
Update
We are continuing to investigate this issue.
Posted Jun 20, 2022 - 23:12 AEST
Investigating
Our planned maintenance activities are taking longer than expected.

Customers can still make payments using their debit card or digital wallet, and withdraw cash from ATMs.

If you’re looking to join ubank, you’ll be able to sign up once we’re back up and running.

We apologise for any inconvenience this may cause and appreciate your support.
Posted Jun 20, 2022 - 23:05 AEST
This incident affected: ubank app.