New customers are unable to join us or apply for Home Loans right now
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Aug 09, 2023 - 11:11 AEST
Investigating
We’re working to resolve this as quickly as possible and we’ll update this page the second it’s fixed.
Posted Aug 09, 2023 - 07:35 AEST
This incident affected: ubank app and Direct home loans.