Our website is unavailable right now
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Jul 31, 2022 - 18:19 AEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 31, 2022 - 18:17 AEST
Identified
We’re working to resolve this and we’ll update this page the second it’s back to normal.
You can still login to internet banking by going to https://www.ubank.com.au/welcome/
Posted Jul 31, 2022 - 17:28 AEST
This incident affected: Online banking.