Our uBank app and Online Banking are not available

Incident Report for ubank

Resolved

This issue has now been resolved.
Posted Sep 01, 2025 - 15:07 AEST

Update

We are continuing to investigate this issue.
Posted Sep 01, 2025 - 14:26 AEST

Investigating

Our app and online banking is currently unavailable right now.
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed. You can still use your debit card and digital wallet as normal.
Posted Sep 01, 2025 - 13:16 AEST
This incident affected: ubank app, Online banking, and Call centre.