Our app’s unavailable right now
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Jul 20, 2023 - 10:44 AEST
Investigating
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Jul 20, 2023 - 10:22 AEST
This incident affected: ubank app and Online banking.