Our app’s unavailable right now
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 00:40 AEST
Identified
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Jun 21, 2023 - 23:40 AEST
This incident affected: ubank app and Online banking.