Call Centre - Degraded performance

Incident Report for ubank

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 14:00 AEST

Update

We are continuing to investigate this issue.
Posted Jun 19, 2026 - 13:44 AEST

Investigating

We’re currently experiencing technical issues with some of our systems, which may affect your ability to connect with one of our advisors right now. We’re working hard to fix this and appreciate your understanding.
Posted Jun 19, 2026 - 13:43 AEST
This incident affected: Call centre.