Our app’s unavailable right now
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 00:49 AEDT
Investigating
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Feb 14, 2024 - 21:14 AEDT
This incident affected: ubank app and Online banking.