Cards are unavailable
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 05:03 AEST
Identified
Card payments are unavailable right now

You won’t be able to use your debit card and digital wallet but you can still pay someone and transfer money using our app. We’ll update this page the second our card payments are fixed.
Posted Jun 06, 2024 - 04:48 AEST
This incident affected: Card payments.