Recent transactions are taking a while to appear
Incident Report for ubank
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 09:58 AEST
Identified
But don’t worry, any transactions you’ve made have gone through and your account balances are up to date. We’ll update this page the second the transactions appear in the app.
Posted Jul 28, 2022 - 21:40 AEST
This incident affected: ubank app and Online banking.